Secure your WordPress install by using WordPress 2.8.5

Yesterday WordPress 2.8.5 was released. Like many of the recent WordPress builds this latest version was compiled with security in mind. Although it has been shown many times that using older versions of WordPress is a security nightmare waiting to happen. End users continue to use builds that should have been retired years ago. There are many people with bad intentions that have used this fact to exploit sites that run old code. WordPress has tried to improve the upgrade process to make it easier and to encourage customers to update when new WordPress builds are available. In almost all cases these versions have been thoroughly tested before release. So there should be no concern about functionality issues or conflicts do to updating.

Web hosting Cloud services Domain registration Webdesign

Debugging WordPress that proves my point

WordPress plugins are just a bunch of teases

WordPress setup plugins install guides help tips news

WordPress 2.8.5: Hardening Release

WordPress Version 2.8.5 Download

WordPress 2.8.5 Out The Door

WordPress Exploit Scanner 0.5

Eric Amundson: 5 Free Ways to Bulletproof Your WordPress Site